KFX 450 HQ Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Have an 09 started yesterday rode for like 10 min ended up killing it started up killed it again and all of a sudden had nothing neutral light would come on bright and when I tried to start it would go dim and click took battery in tested bad got a new one now soon as I turn the kill switch over it clicks in the second from left relay and when I go to hit the start button its stops but goes back to clicking when I let off and just wont do anything i can pull start it and runs fine till I shut it off any ideas on where to start to diagnose?
 

·
Super Moderator
Joined
·
9,617 Posts
Welcome to the forum...!!!

Check if the decompression spring fell off the exhaust cam...see picture

Also check the starter relay/30 amp fuse block's harness contacts & connection to be clean & free from moister...see picture
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Do I pull valve cover to check decompression spring? Also gonna get a different battery I checked voltage at the starter solenoid and I'm only getting 5.6 volts and checked at the battery and same so I'm thinking may still just be bad battery
 

·
Registered
Joined
·
13 Posts
Dust devil has definitely pointed you in a good direction. Often times when you here clicks only when hitting the starter it can be the starter solenoid is bad as well. I know I experienced that with a raptor I had in the past.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Turns out it was just the battery got a new gel battery that was tested and good put it in and fired right up three different advance auto stores had bad batteries brand new out of the box including the one I bought
 
1 - 6 of 6 Posts
Top