KFX 450 HQ Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
558 Posts
Discussion Starter #1
Hey guys, finally finished my winter project wherei painted the motor and swingarm (post tomorrow about that) and got to stsrt it today. Only problem is sometimes when j hit the throttle from idle (either a quick jab or light touch) it will shut off. I think it is something with the fuel controller at idle. Maybe too rich or lean but does anyone know why its doing this? Thanks
 

·
Registered
Joined
·
8 Posts
My quad did the same thing check the wires running to the intake and make sure they’re tight check idle speed should be around 800rpm if you have any other problems with the bike message me if u need text me and I will send you some pics of what had happened to my quad


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
558 Posts
Discussion Starter #3
I had the entire thing completely apart and upon reassembly i can assure you all the connections are tight. I also took apart the throttle body and cleaned the inside of it (couldnt believe all the gunk in the idle air bypass hose channel area). You meant 1800 rmp too right? Yes mine is +-1800rpm. Is that all that was wrong with yours? Thanks a ton!
 

·
Registered
Joined
·
558 Posts
Discussion Starter #4
Sneak peek of the motor also for ya
 

Attachments

·
Registered
Joined
·
8 Posts
No idles should be 800rpm not 1800 rpm put a little dielectric grease on the connectors and chew I the on that by the frame the throttle adj there’s the plug next to that on the intake and if it’s just a little off it will die when u slam on the throttle make sure the bike has warmed up enough be careful with adj (I got a moose racing air filter and, hmf full exhaust, hmf fuel controller, on my 7th repair of the engine) make sure u have checked everything over all wires and fuses under the hood watch your engine temp 450s run hot text my number 701-526-6801


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
558 Posts
Discussion Starter #7
Not trying to say u dont know what ur talking about but when my idle adjustment is 22 clicks out ( runs better at 20) and when it is at 20 out it id at at 1800 rpm which the manual also says. Am i misunderstanding something? Thanks
 

Attachments

·
Registered
Joined
·
171 Posts
Mine idles between 1700-1800 according to the trail tech and runs great!


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
558 Posts
Discussion Starter #9
Yea, thats what mine says too. Got the machine runnin a but better but when its idling and i give it a quick wot jab it will still cut out. Seems that when im cruising in 1st or second low rpms i can hear some sort of popping and i know its not backfire but im concerned it is being too lean or detonating. Was suggested to me to get it taken to a dyno tuner which ill probaly have to do but im having trouble finding places. Current adjustments are Green 3.5 orange 5.5 Red 3 (stg 3 hotcams,dasa,fci,motoworks controller)
 

·
Registered
Joined
·
558 Posts
Discussion Starter #11
Yes. Before i riched it up a teeny bit it was tan.
 

·
Registered
Joined
·
286 Posts
Looks great Jacob!

The engine colors are very cool, did you use VHT paint
 

·
Registered
Joined
·
558 Posts
Discussion Starter #13
I used Duplicolor Cremic Engine Enamel and worked great. I put out another thread that has many pics if you are interested.
 

·
Registered
Joined
·
286 Posts
Oh yes Duplicolor thats it :tango_face_smile:

And yup I saw your other post with more pics of the full bike, I must have responded to the wrong one again

My bad Bahahahah
 
1 - 14 of 14 Posts
Top