KFX 450 HQ Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Im new to this but i have an 08kfx450 and i have a problem with the starter. when i go to start it up the starter will act like i have very low battery voltage, i went out and got a new battery and the same thing happened, its like the starter is getting stuck or hung up for a second, it will start just takes a couple of tries then it will spin fast enough to start. also i have coolant coming fron the weap hole on the water pump, its mainly when i start it to let it warm up.

Any thoughts?
 

·
Registered
Joined
·
3,488 Posts
Like I mentioned on the other thread, it sounds like your auto decomp to me. As for the weep hole, I would think if the gasket was bad it'd be all the time, but that's my guess. Make sure you check your oil to see that coolant isn't getting into the cases.
 

·
Registered
Joined
·
159 Posts
It's a spring loaded weight on the Exhaust cam that makes it easier for the starter to turn over the motor... simple explanation...
 

·
Registered
Joined
·
3,488 Posts
It could be, or your bolt coulda came loose. Are you asking where to buy one of where it is located? Like he said, it's located on that exhaust cam, so just under the valve cover. If you're looking to buy one, I'd try motosport.com. Take that valve cover off and check it out first.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
well i took the valve cover off and the decomp spring is missing, i dont know if the previous owner took it out or if it broke and fell into the botom of the motor, i have riddin it probably five times like this and now it makes me nervous to run it fearing it may be in the botom of the motor and screw somthing up, any advice?
 

·
Registered
Joined
·
3,488 Posts
I've heard of someone else running for a long time w/it down there and it never caused issues, but I don't know that I recommend it. It's just a small spring. I'm glad we were right about what the issue was though, and it should be an easy fix. I'm guessing that spring is wedged somewhere by now that it won't cause problems.
 

·
Registered
Joined
·
52 Posts
Mines doing this recently too. I was gonna buy a battery but now Im not. It just has a really really weak crank when I start it, then kills the battery after a few minutes of trying to start it. Is it hard to take the valve cover off? I have mechanical knowledge, I just dont want to screw anything else up in the process..
 

·
Registered
Joined
·
440 Posts
well i took the valve cover off and the decomp spring is missing, i dont know if the previous owner took it out or if it broke and fell into the botom of the motor, i have riddin it probably five times like this and now it makes me nervous to run it fearing it may be in the botom of the motor and screw somthing up, any advice?
my spring broke and fell down under the stator, I didn't have any issues. but if you want to get it out all you should have to do is remove the stator cover and it should be right there.
 

·
Registered
Joined
·
3,488 Posts
Mines doing this recently too. I was gonna buy a battery but now Im not. It just has a really really weak crank when I start it, then kills the battery after a few minutes of trying to start it. Is it hard to take the valve cover off? I have mechanical knowledge, I just dont want to screw anything else up in the process..
Nope. There are three bolts. That's it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #13
well i got the new spring on there and it starts up just fine, now i just have to get the water pump deal figured out and im good to go, thanks for the info guys
 

·
Registered
Joined
·
3,488 Posts
Glad you got it straightened out. My guess is that the issue w/the pump is just the gasket. Most likely a very simple fix. :)

If you wanna keep from draining all your coolant tip if up on the left side and support it with a stand or blocks on the bars to work on it. That way only some will drain.
 

·
Registered
Joined
·
159 Posts
Glad you found the problem. don't think the spring will be an issue if you dont find it.
 

·
Registered
Joined
·
139 Posts
if this spring did come out would it make the motor sound like something was rattling. this weekend my motor started sounding like something was loose. i just replaced the the cyclinder and piston dont think i left anything loose. it sounded normal the weekend before.
 

·
Registered
Joined
·
12,056 Posts
Zfet,

Go over in the Important Information section.

I have a "how to" written up over there.

There is nothing to it... don't be skeerd... go have a look to see what you are getting into... then go get into it...
 
1 - 18 of 18 Posts
Top