KFX 450 HQ Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
Hey guys just wondering what would cause the
28904
28905
steels to turn this color and the fibers still be in good shape
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #3 ·
I was using mobile 1 4t 10w40 but I had to use conventional valvoline 10w 40 to break in hotcams that was 2 or 3 rides ago and just did the oil and clutch because it felt like it was slipping but the frictions were great looked almost new but I've had it for a lil over a year and was completely stock when I got it
 

·
Super Moderator
Joined
·
10,049 Posts
I was using mobile 1 4t 10w40 but I had to use conventional valvoline 10w 40 to break in hotcams that was 2 or 3 rides ago and just did the oil and clutch because it felt like it was slipping but the frictions were great looked almost new but I've had it for a lil over a year and was completely stock when I got it
Does it slip with the valvoline..?
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #6 ·
Ok so I put s hinson fiber steel springs kit in holy hell wat a deference and no slipping maybe the oem springs were weak idk but I hooks up nice now
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #8 ·
yes i did clutch is fine but now i got a problem that when i turn the bars to the left it dies checked the harness no rubs any ideas
 

·
Super Moderator
Joined
·
10,049 Posts
yes i did clutch is fine but now i got a problem that when i turn the bars to the left it dies checked the harness no rubs any ideas
Check the light switch/starter button assembly where it connects to the wiring harness for being loose or dirty connection...

Also check the 30 amp starter solenoid red harness connection...see pics
 

Attachments

·
Registered
Joined
·
2,097 Posts
From my experience that 10w-40 conventional valvoline is like water.
Your clutch saw a lot of heat.
I just installed a Hinson fiber and steel kit and it’s working well
 
1 - 10 of 10 Posts
Top