KFX 450 HQ Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
was running fine, shut it off to hop off and move a branch laying in the middle of the trail. got back on and when i turned the key on and electric, the fuel pump wasnt filling up like normal. And i would try to start it, just kept turning over, but wouldnt actually fire up. dk why, guessing since i didnt hear the fuel pump fill up, and its not starting... thats my problem.

before i got into and have to look up the diagnostic codes figured i would ask here. Anyone experience this problem? and if im correct, any idea where to get a good/decent fuel pump that wont kill my wallet.
 

·
Registered
Joined
·
1,310 Posts

·
Super Moderator
Joined
·
9,899 Posts
Check the Fuel pump relay and 10 amp fuse and make sure there good...

Then check the fuel pumps electrical connection and too make sure it's good...

direct wire the fuel pump to the battery and make sure it's not working...

once confirmed then purchase a new/used pump, hate to see you shell out money if you don't have too...
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
10 amp fuse under the orange cap, right?
 

·
Registered
Joined
·
38 Posts
Discussion Starter #6
alright fuses are good.

the 12 volt relay test open (ol) on all leads. does it have to be hooked up to read continuity? or should it show something when it is disconnected to?
 

·
Super Moderator
Joined
·
9,899 Posts
alright fuses are good.

the 12 volt relay test open (ol) on all leads. does it have to be hooked up to read continuity? or should it show something when it is disconnected to?
No. see picture...leads 1&2 should be closed...
Leads 3&4 should be open. ...All open then the relay is bad coil is burnt and needs to be replaced...swap it with the clutch or neutral starter relay and see if the fuel pump primes/works...
 

·
Registered
Joined
·
12,056 Posts
While you have the relay unhooked, make sure you are getting 12v trip/supply voltage from the yellow/red wire too. Could be the thumb switch as well.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #9
alright, now that i have the weekend off from both jobs time to get this thing fixed. i took both relays off the left hand side of the metal bar that goes across and dont remember which one is which. is the fuel pump the one with mostly blue wires or white and yellow? im about to put the relays on from the right hand side and test (both left since i dont know which one is fp) and hopefully trial and error will tell me (if its the relays that went bad).
 

·
Super Moderator
Joined
·
9,899 Posts
alright, now that i have the weekend off from both jobs time to get this thing fixed. i took both relays off the left hand side of the metal bar that goes across and dont remember which one is which. is the fuel pump the one with mostly blue wires or white and yellow? im about to put the relays on from the right hand side and test (both left since i dont know which one is fp) and hopefully trial and error will tell me (if its the relays that went bad).
Also check your overturn sensor is still on the bracket...???
 

·
Registered
Joined
·
38 Posts
Discussion Starter #11
well just found out it was the relay. ordering today, thanks for all the help
 

·
Registered
Joined
·
12,056 Posts
well just found out it was the relay. ordering today, thanks for all the help
Great news the problem is solved and it's an easy fix without being to expensive, Enjoy!...:D
I have the same problem myself right now...

And no it is not a particularly cheap fix for what it is.

(relay price is each, not for all 4)
 

·
Super Moderator
Joined
·
9,899 Posts
well just found out it was the relay. ordering today, thanks for all the help
Great news the problem is solved and it's an easy fix without being to expensive, Enjoy!...:D
I have the same problem myself right now...

And no it is not a particularly cheap fix for what it is.

(relay price is each, not for all 4)
Oops i thought wrong...:(

Good thing I buy used wiring harnesses on Ebay that include the relays and some of the sensors for under $100.00...

this one includes the throttle body $130.00 + shipping..http://www.ebay.com/itm/08-KAWASAKI-KFX450R-WIRING-HARNESS-THROTTLE-KFX450-KFX-/390440413582?pt=Motors_ATV_Parts_Accessories&hash=item5ae80fe98e&vxp=mtr

Cheaper than buying them each at a OEM parts store..
 

·
Registered
Joined
·
38 Posts
Discussion Starter #15
What are you saying? I only am replacing the one relay for $38
 
1 - 16 of 16 Posts
Top