KFX 450 HQ Forum banner

1 - 10 of 10 Posts

·
Registered
2008 kfx450r
Joined
·
5 Posts
Discussion Starter #1
1. Turn key on and fast clicking occurs at the location the wire goes into the throttle body.
2. Next i turn the red switch to the on position and the clicking moves from the throttle body to the fuel relay under the hood .
3. Side note if i turn the lights to the on position the clicking stops.
4. HAS new battery, new stator,voltage rectifier, crank switch, 2 x 10 amp fuses,1 x 30 amp fuze.
Cranks over fine but has no spark.
5. ignitiin coil test
Primary winding within ohm spec 2.5. ohm
Secondary winding reads 18.44 ohm. spec says 11 to 16ohms.
6. Rollover sensor installed correctly
7.tested main relay with 30 amp fuze according to service manual tests good.
Any help greatly appreciated
 

·
Super Moderator
Joined
·
9,936 Posts
Welcome to the Forum...!

DON'T TOUCH the throttle (giving it gas) once the key is turned on until the motor is running or IT WILL NOT START...!!!!

Make sure the new battery is fully charged to 12.8v standard...

Test for 12v on the Y/R wire at the ignition coil to frame ground...see picture

Make sure the throttle cable has a little slack to close the butterfly to idle position...

Check the TPS/throttle positioning sensor voltage to be in range...see picture

Test the output voltage of the roll over sensor...see picture
 

Attachments

·
Registered
2008 kfx450r
Joined
·
5 Posts
Discussion Starter #3
To test voltages on the Rollover sensor so i have to cut the wires. Have a service mamual butnits not always clear
Welcome to the Forum...!

DON'T TOUCH the throttle (giving it gas) once the key is turned on until the motor is running or IT WILL NOT START...!!!!

Make sure the new battery is fully charged to 12.8v standard...

Test for 12v on the Y/R wire at the ignition coil to frame ground...see picture

Make sure the throttle cable has a little slack to close the butterfly to idle position...

Check the TPS/throttle positioning sensor voltage to be in range...see picture

Test the output voltage of the roll over sensor...see picture
12.78 volts on battery
1. Touched voltage tester to terminals on ingition coil snd clicking stopped, measuted 12.30 v.
2.turned motor over to see if there was spark and clicking started again no spark.measured voltage at same location again no voltage. Put positive lead on coil snd negative on battery ground and got 12.30 v
 

·
Super Moderator
Joined
·
9,936 Posts
The fuel pump & injector share the relay...the clicking sound might be the injector...

Is your quad all stock or has upgrades...??

Stick the meter leads or needles into the back of the roll over connector to test the voltage...
 

Attachments

·
Super Moderator
Joined
·
9,936 Posts
How do you check wit a tester for shorts
Double check the battery connections to be correct polarity... positive to positive & negative to negative...!

The relay might be bad causing it to chatter...!!!
First swap out the fuel pump relay with one of the other relays to see if the problem continues...If it stops...Bad relay, simply replace it

same as testing OHMs resistance....check the continuity through the circuit & to frame ground for shorts...
 

·
Registered
2008 kfx450r
Joined
·
5 Posts
Discussion Starter #9
Replaced ecu with procom and xlicking stopped.still no spark to the plug
 

·
Super Moderator
Joined
·
9,936 Posts
Replaced ecu with procom and xlicking stopped.still no spark to the plug
Not sure...This is the first for me...relay & injector clicking like that...

Did you check if you connected the battery correctly & not reverse polarity...????
 
1 - 10 of 10 Posts
Top