KFX 450 HQ Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi Im new here, recently I bought a 08 kfx450r the atv has around a year without use. I make general maintence. the atv starts and run normal. In the first run works great the second not when I went in a downhill I went witouth accelerating and finish the downhill and I start to accelerate but the atv no accelerate it just loses power and the exhaust explodes, until the atv loses speed and stops and shuts down. The first time it happened it turned off and I turned it on again and it worked normally but now when it shut off its very hard to turning on again and always has the problem of acceleration. Self diagnosis shows that the Crankshaft sensor its bad I meassure the crankshaft sensor recistance and its on 190 ohms when the atv its cold, when its hot no recistance. When the atv is turned off and you move the key for turning on the first led blinks infinitely never stop flashes when you turn on the atv the led turned off.

I need some advice because the sensor of the crankshaft as far as I know does not cause the problem that it does not accelerate when it is going. Generally the problem occurs when the atv has a long time running and also when the trip is long at the beginning it does not fail but when the trip takes about an hour it begins to fail. I do not use the atv in the city only for cross country. The atv is completely stock only the exhaust that has one of the LEXX brand

thanks in advance
 

·
Super Moderator
Joined
·
10,145 Posts
If the F.I dash light is flashing non stop...check the vehicle down sensor for being on the perch with arrow up...see pic

If you can check the crank sensors peak voltage 2v or more normal .see pic analog voltage meter is recommended to watch the needle bounce..
 

Attachments

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
If the F.I dash light is flashing non stop...check the vehicle down sensor for being on the perch with arrow up...see pic

If you can check the crank sensors peak voltage 2v or more normal .see pic analog voltage meter is recommended to watch the needle bounce..
I dont have the adaptor for meassure peak voltage. I'll have to buy the sensor. But what do you think this sensor can affect the problem that when I accelerate it is like I decelerate?

thank you
 

·
Super Moderator
Joined
·
10,145 Posts
I dont have the adaptor for meassure peak voltage. I'll have to buy the sensor. But what do you think this sensor can affect the problem that when I accelerate it is like I decelerate?

thank you
Check your harness wires & connection to your crank sensor with an ohms meter...!!

Crank sensor is not sold separately you'll have to buy the stator for $300.00 ... Buy a analog meter for $10.00 and set it for the lowest AC voltage & watch the needle bounce as you hold down the starter button...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Check your harness wires & connection to your crank sensor with an ohms meter...!!

Crank sensor is not sold separately you'll have to buy the stator for $300.00 ... Buy a analog meter for $10.00 and set it for the lowest AC voltage & watch the needle bounce as you hold down the starter button...
thanks ill try and comment
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
Check your harness wires & connection to your crank sensor with an ohms meter...!!

Crank sensor is not sold separately you'll have to buy the stator for $300.00 ... Buy a analog meter for $10.00 and set it for the lowest AC voltage & watch the needle bounce as you hold down the starter button...
what about the sensor from $60.00 on ebay?
 

·
Super Moderator
Joined
·
10,145 Posts
what about the sensor from $60.00 on ebay?
I found this one on Ebay for $30.00...I say you should try it & see...!
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
I bought that and start, also change the fuel pump filter and work great 5 minutes after that the fuel pump don’t work :(
 
1 - 11 of 11 Posts
Top