KFX 450 HQ Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a stage 3 hot cams with big aluminum airbox intake, high compression head at 13.1, full two brothers exhaust and a PCIII but I am having mayor problems tunning it., I loose power at 8k rpm we gave it as much fuel as permited by the PCIII but it continues to choke at full throttle., Do i put the OEM cams bac or should I change to stage 2., Please help as we are going crazy with this., Any suggestions......
:confused::confused:
 

·
Super Moderator
Joined
·
10,145 Posts
I'm running stg 3 with a velocity intake and I have no problem feeding it with a Dynatek F.I controller...

Check your spark-plug for fouling or replace it....

What fuel octane are you running???

And did you check your TPS voltage and TPS wire & PC III wire connection...???

Check your throttle body manifold and intake boot clamps...

Have you tried other maps??? one with no air-box & full exhaust...
 

·
Super Moderator
Joined
·
10,145 Posts
Question !!! did you drop the cams in without checking the valve clearance ?????

Check the valve clearance/lash...

exhaust 0.17-0.22 mm (0.0067-0.0087 in.)
intake 0.10-0.15 mm (0.0039-0.0059 in.)
 

·
Registered
Joined
·
1 Posts
Hey, I have stage 3 cam’s in my quad as well, it’s at the shop right now, they claim everything is to spec, including the voltage to everything and the fuel and air are perfect. it’s starts and runs good for about 20 minutes then it dies and won’t start tell its cooled down, it’s not over heating though, we already checked all that off, it started happening after I told the dealership to do a valve adjustment, the mechanic said “they had the wrong buckets in there, so I put the right ones in” and then it started to happen, do stage 3 cam’s need certain buckets? Please help
 

·
Super Moderator
Joined
·
10,145 Posts
Hey, I have stage 3 cam’s in my quad as well, it’s at the shop right now, they claim everything is to spec, including the voltage to everything and the fuel and air are perfect. it’s starts and runs good for about 20 minutes then it dies and won’t start tell its cooled down, it’s not over heating though, we already checked all that off, it started happening after I told the dealership to do a valve adjustment, the mechanic said “they had the wrong buckets in there, so I put the right ones in” and then it started to happen, do stage 3 cam’s need certain buckets? Please help
No..! I'm running Hotcam stg3 with stock buckets...Not sure what the mechanic's means wrong buckets...

I think your being scammed for more money...Do your own valve clearance check...?

Valve Clearance: between cam and valve lifter
Standard:
Exhaust 0.17 ∼ 0.22 mm (0.0067 ∼ 0.0087 in.)
Inlet 0.10 ∼ 0.15 mm (0.0039 ∼ 0.0059 in.)
If the valve clearance is not within the specified range,
adjust it.
 

Attachments

1 - 5 of 5 Posts
Top