KFX 450 HQ Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hello fellow kfx 450 owners im in need of some dear help and im am stumped maybe one of you guys can help me get this figured out sorry if im posting in the wrong spot just please politely point me in the right direction ..........I own a 08 Kfx450 info on build

ProCom ecu
PCV (fuel only)
Hotrod 3mm crank
100mm je piston 13:0:1
CT racing head ported polish
+1 Valves
dasa throttle body bore
webcams 242/216 grind
FCI
accel coil

So the bike will start perfectly on a cold start once bike gets to running temperature and i were to shut it off it is very hard to start. I will have to wait for about 15-20 min before it will start again. now i know your thinking TIGHT VALVES VALVES VALVES lol or TPS sensor but i have literally checked valves over 100 times due to me having the webcams it asks for .006"-.008" Intake and .008"-.010" Exhaust which I have them perfectly set at the moment .008" on intake and .010" Exhaust. I also noticed my fan is not turning on. So i jumped the fan relay and fan works so i purchased a new water temp sensor from ebay 20 bucks cool! started it let it run to operating temp waited for fan and nothing turned off motor tried to start again wont start have to wait until motor is cool again. So i though maybe the ECU is the problem well thankfully i own 2 procoms so i swapped ECU STILL NO FAN checked to see if any break in the wire and none!!!
also switched all Relays around still the same outcome. also swapped piston and cylinder had a wossner 12:1 recently switched to JE 13:1 but never got a tune for the new piston could this be my problem also notice spark plug is black?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
Does anyone know if map 10 on the procom ecu will be efficient for fuel for my mods on the quad? CUrrently using procom and PCV at the same time?
 

·
Registered
Joined
·
1,972 Posts
Web cams call for a tighter tolerance than other cams?

Typically .010-.014 is the spec for intake

And .017-.022 for exhaust

Map 9 should be a good start.

Are you running atleast 100 octane fuel?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Yes running 100+ octane vp fuel.....so even though webcam instructions wants those specific valve clearance you still suggest going to the factory valve clearance?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Ok took it to the shop they said my issue is that the procom and PCV are working against each other they put it on a dyno and said readings of the PCV were showing double everything and it’s just shooting to much fuel and firing when piston is at top and bottom. they advised me to order the OEM ecu what do you think duster?
 

·
Registered
Joined
·
1,972 Posts
Yes the procom read wasted spark!

That will double everything on the dynojet.

Contact dynojet and get a update to read wasted spark (.5)

Or get a stock ecu and tune the dynojet.

Or remove the dynojet and just run the procom
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Would love to run only procom but no one knows how to use the software which puts me in a bind. any recommendations on people who are familiar with the procom software?
 

·
Registered
Joined
·
1,972 Posts
The software is pretty simple for procom. See if your local dyno shop will work with it.

Otherwise a stock ecu and pcV will be easier to tune
 
  • Like
Reactions: KB Motorsports

·
Registered
Joined
·
13 Posts
Discussion Starter #9
Thank you bluestroker for your help You were absolutely right!!!!! the PCV is tuned as close as we could get it on the dyno with the procom BUT with the procom very very very hard start once warm then would switch to oem ecu and it will start perfectly. im going to contact Power commander for the firmware update.....OR if anyone else is seeing this that may have the file hopefully someone can help me out my email is [email protected]
 

·
Registered
Joined
·
12,056 Posts
I don't have access to the file you need. But you only need one of the two units or provo on 0 and the file and a tune.

If they are rich they don't start good hot that is for sure.
 

·
Registered
Joined
·
1,090 Posts
I don't have access to the file you need. But you only need one of the two units or provo on 0 and the file and a tune.



If they are rich they don't start good hot that is for sure.


This is totally off topic but a lot of time especially in high hour machines the intake valves being tight cause a lot of trouble when trying to start hot. I would check valve clearance if it starts easily cold and runs great.
 
1 - 11 of 11 Posts
Top