KFX 450 HQ Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hello Everyone,
How long is normal to hold the starter button in before it starts? The longer I hold it in obviously the more it drains the battery. The reason I ask is most times I have to hold the starter button in for like 10 second (or more) before it turns over - even with choke pulled out. I feel 2-3 seconds should be normal with it being fuel injected.
What would be the cause for this taking so long to turn over?
The spark plug is new, My idle "clicks" equals 21. I use 93 grade gas.

Once it finally starts it runs pretty good, but I find I drain my battery alot and I'm charging it alot. Maybe I should try a NEW battery? The one I have is not very old.
 

·
Registered
Joined
·
13 Posts
I have experienced slow starting in the past. A new battery definitely improved things for me. I remember reading on here how important a good battery was for the Kfx. I never thought much of it and was buying cheap $30 batteries, then I bought a good battery. It definitely improved starts, both cold and hot.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
I almost bought this Lithium battery... (FirePower Featherweight Lithium Battery HJTZ7S-FP-IL)
... but decided not to spend the extra money on Lithium. What I liked about it is that is was not as TALL, so it would be easier to get the terminals off and get the battery out.
I have a Tender charger that was NOT lithium, so I went with a standard battery. The new battery with my old tender charger seems to make a big difference in starting.

I still need to "choke" when hot which is odd to me and I do not know what would cause that?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
It starts right up cold (choked). But I need to leave it warm up and SLOOOWLY push the choke back in AND give it throttle for the idle to stick while choke is in. Once it warms up, the choke is in and it's idling on it's own it runs good. Sounds good when running no noises or rattles. My issues are...
1.) When I come to a stop in 1st gear (with clutch in) it stalls
2.) Hard-er to start when hot, but it eventually does
3.) Sometimes have to choke it again to start when hot
I am checking the "TPS voltage & adjust it to 0.62v" this weekend, when I receive my multi meter from amazon.
 
1 - 6 of 6 Posts
Top