KFX 450 HQ Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Not sure if this is in the right spot. Can anyone point me to a video of a wiring harness installation? I can only dind yfz.
thanks
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
I got the wiring harness connected and it still making the same clicking noise. The noise sounds like it is coming from the little black box near the handlebars.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 ·
I’ve replaced the starter solenoid 2 times already. The first time it fired right up for a few tries then it died again. Replaced it again and just clicking. I can try to post a video if that will help.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #8 ·
Clean all the connection of the wiring harness that connect into the solenoid...Double check your 2 grounds...Main by the starter & fuel tank mounts...!!
I’ve cleaned and double checked everything. It still makes the clicking noise and doesn’t start.
is there any chance it could be the starter?
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #11 ·
The starter one-way clutch on the crank might be bad...
I went ahead and ordered a starter for it yesterday before there were any replies about it. The one way clutch bearing is gonna have to wait til next week. What I don’t get is, it started fine for a few days and all of a sudden quit, the only thing working are the lights. No way it could be the ECU?
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #12 ·
Well I got the wiring harness connected the other day and the starter got done earlier. It started right up 2 times in a row then what do ya know? The friggin air filter caught fire. Just my luck. So now I’m waiting for that.
 
1 - 12 of 12 Posts
Top