KFX 450 HQ Forum banner

21 - 36 of 36 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #21
So I got the valve cover off and the guy has put yamalube over the entire thing. Every single gasket on here even around the fkn valve cover bolts. He obviously had no clue what he was doing. So when I took the valve cover off I tore it a bit cause it was basically glued on. I ended up ordering a new one it should be here next week sometime. Ill keep you guys updated. Looking at the chain it appears to have stretched just a little bit. not much
 

·
Super Moderator
Joined
·
9,933 Posts
So I got the valve cover off and the guy has put yamalube over the entire thing. Every single gasket on here even around the fkn valve cover bolts. He obviously had no clue what he was doing. So when I took the valve cover off I tore it a bit cause it was basically glued on. I ended up ordering a new one it should be here next week sometime. Ill keep you guys updated. Looking at the chain it appears to have stretched just a little bit. not much
If the cam chain tensioner was installed improperly will damage the cam chain & tensioner...!!

Make sure the cam chain tensioner is good & was installed properly..!

make sure the oil sump screens are clean & not plugged up... How to clean oil screens with pics
 

Attachments

·
Registered
Joined
·
28 Posts
Discussion Starter #23
I bought a new psr manual chain tensioner and chain. I'm just waiting on valve cover gasket. Also there is play in this gear it is normal? what is it for? water pump gear? check my video
 

·
Registered
Joined
·
28 Posts
Discussion Starter #26
So I was in a rush and made a rookie mistake. I was putting the battery on and I got the terminals mixed up, ik I'm a idiot. 30amp fuse is good.. did i fry voltage regulator?
 

·
Super Moderator
Joined
·
9,933 Posts
So I was in a rush and made a rookie mistake. I was putting the battery on and I got the terminals mixed up, ik I'm a idiot. 30amp fuse is good.. did i fry voltage regulator?
Hopefully! It's the regulator...It's the ECU/computer you should be worried about frying...!!!

Test the regulator see pic
 

Attachments

·
Registered
Joined
·
28 Posts
Discussion Starter #28
I was looking at the spare last night haha. 2 many beers lol... The 30amp did blow though and I replaced that and now it still won't start. It's sitting at my dads and I wont be there till Saturday. I can here the fuel pump come on is there a chance I could've blown the fuse for that?? left red light comes on when I'm starting it what does that mean?
 

·
Super Moderator
Joined
·
9,933 Posts
I was looking at the spare last night haha. 2 many beers lol... The 30amp did blow though and I replaced that and now it still won't start. It's sitting at my dads and I wont be there till Saturday. I can here the fuel pump come on is there a chance I could've blown the fuse for that?? left red light comes on when I'm starting it what does that mean?
The F.I dash light staying ON means you have a DFI error... see pictures.

Find the orange wire in a black pouch & ground it to the frame, turn ON the key a count the F.I dash lights blink out the code...
 

Attachments

·
Super Moderator
Joined
·
9,933 Posts
only comes on when I'm pushing the ignition like this guys Help!!! Fi light flashing when pushing ignition?!?!?!?
"First" Test the output voltage of the vehicle down sensor...If good/working properly.. The fuel injector is not opening thus test the injector nozzle resistance...see pictures

If the resistance of the nozzle is good...Then the ECU maybe the problem...Now test the input voltage of the vehicle down sensor range is 4.75~5.25 DCV ..see picture
 

Attachments

·
Registered
Joined
·
28 Posts
Discussion Starter #34
Just pulled the injector and its not misting fuel like it should when i have it plugged in. Ill probably look at it tmrw more. :(
 
21 - 36 of 36 Posts
Top