KFX 450 HQ Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
hello i have and 08 set up for mx, i have been having problems with my front brakes for almost 6 months now, they will grab a littel but not what what they should be, i have bleed and replaced pads and bleed again and again and again, i have gone threw a whole bottel of fluid, no air, just spungy brakes what is the problem?

thanks!!
 

·
Registered
Joined
·
5,216 Posts
Id recomment replacing the lines galflers are pretty nice and around 60-70 bucks u may also need a master cylinder rebuild kit or replace the hole thing sounds like theres still air trapped in there!make sure all the brake line bolts are tight as well!
 

·
Registered
Joined
·
12,058 Posts
Do you have an aftermarket brake reservoir cover on it?

For some reason I have still never figured out, I used to randomly loose my front brakes. I would reach for a two finger grab and the lever would come right in to my other fingers and nothing. Sometimes a couple pumps and I could get a little brake. Then one day I took the cover off and just pumped a couple of times and they firmed right up. After going through this a couple of times I changed that cover as that was the only odd thing. Same happened to a friend of mine.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
i have stream line break lines, all bolts are tight, oem res cover, im thinking the master cylinder or the calipers is the problem?
 

·
Registered
Joined
·
34 Posts
If the lines are good and your positive there's no air in it, rebuild the master cylinder or replace it. My first guess would not be a caliper because both sides are affected.
 

·
Registered
Joined
·
12,058 Posts
Ditto on that...
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
i havent had time to tear apart the breaks threw the week, i need it running for the weekend races, when i get to it ill keep you informed, thanks for the help!!
 
1 - 7 of 7 Posts
Top