KFX 450 HQ Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I’m very confused. My buddy dropped his quad off to me today for me to put a new starter clutch in it. After doing that I tried to start it. I couldn’t get it to fire so I pulled the spark plug. The spark plug was covered in green fluid (coolant). So he decided to put a head gasket in. The head gasket fixed the coolant leaking into the cylinder. But, it still won’t start. I tried and tried again to get it to start, but it won’t. It sputtered here and there but wouldn’t catch. I pulled the spark plug and there was some fuel on it, so I cleaned it. It has good spark, and it is getting fuel, and has good compression, but it won’t fire. I’m wondering if it’s getting too much fuel. When I pulled the fuel tank off it wouldn’t stop leaking gas out of the pump. The pump is only a few months old. I’m really stuck for ideas. Anything helps at this point. Thanks in advance
 

·
Super Moderator
Joined
·
10,076 Posts
I’m very confused. My buddy dropped his quad off to me today for me to put a new starter clutch in it. After doing that I tried to start it. I couldn’t get it to fire so I pulled the spark plug. The spark plug was covered in green fluid (coolant). So he decided to put a head gasket in. The head gasket fixed the coolant leaking into the cylinder. But, it still won’t start. I tried and tried again to get it to start, but it won’t. It sputtered here and there but wouldn’t catch. I pulled the spark plug and there was some fuel on it, so I cleaned it. It has good spark, and it is getting fuel, and has good compression, but it won’t fire. I’m wondering if it’s getting too much fuel. When I pulled the fuel tank off it wouldn’t stop leaking gas out of the pump. The pump is only a few months old. I’m really stuck for ideas. Anything helps at this point. Thanks in advance
Here's the service manual

Make sure the battery is full y charged...12.8 volt standard...!!!

Does the F.I dash light remain on or flashing when starting..?

Don't touch the throttle once the key is ON & motor is running...will cause an DFI error...!!

Check the valve clearance...?

Make sure the TPS/Throttle positioning sensor is in range...?
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Here's the service manual

Make sure the battery is full y charged...12.8 volt standard...!!!

Does the F.I dash light remain on or flashing when starting..?

Don't touch the throttle once the key is ON & motor is running...will cause an DFI error...!!

Check the valve clearance...?

Make sure the TPS/Throttle positioning sensor is in range...?
The FI light doesn’t stay on when trying to start, my next option is pulling the fuel pump apart to see if it’s making good pressure then I’m gonna try to calibrate the tps
 
1 - 3 of 3 Posts
Top