KFX 450 HQ Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello guys for starters I am new with the site lots of great info here and glad to be apart.

I recently bought a kfx450 and it had some issues I could get it to run but it would crank and crank then finally start enough with working the throttle to keep it going never could get it to idle for any period of time maybe tops 5 secs without dying I took it down the road and hit the throttle it just spuddered seemed fuel related I took the seat off and seems the throttle body boot was loose. From what I can tell it has a hmf slip on and maybe a intake lid removed. It seems that around the case there’s new gaskets and stuff so possible rebuild but not sure I ended up taking the valve cover off today lined up the marks and found this picture attached looks off to myself but I am unsure I was going to reinstall and check valve clearance this evening also check tps voltage any info on this would be greatly appreciated.
28954
 

·
Super Moderator
Joined
·
10,076 Posts
Hello guys for starters I am new with the site lots of great info here and glad to be apart.

I recently bought a kfx450 and it had some issues I could get it to run but it would crank and crank then finally start enough with working the throttle to keep it going never could get it to idle for any period of time maybe tops 5 secs without dying I took it down the road and hit the throttle it just spuddered seemed fuel related I took the seat off and seems the throttle body boot was loose. From what I can tell it has a hmf slip on and maybe a intake lid removed. It seems that around the case there’s new gaskets and stuff so possible rebuild but not sure I ended up taking the valve cover off today lined up the marks and found this picture attached looks off to myself but I am unsure I was going to reinstall and check valve clearance this evening also check tps voltage any info on this would be greatly appreciated. View attachment 28954
Welcome to the Forum...!!!

Yes, check the valve clearance & TPS to be in range...!

Make sure your battery is fully charged...12.8v standard...!!

Does your F,I light remain ON or flashing...?

Make sure your vehicle down sensor is mounted on it perch...!!!
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Yes sir thanks a lot have been searching your helpful replies to everyone else for years and glad to have you around. Thanks a lot for providing the info and battery has been on charge and seems to be good light does NOT stay on and sensor is mounted correctly. Also I am not sure if my fan is working properly it does work jumped out and with the coolant temp sensor unplugged and key on it does not come on with key on before startup with sensor plugged up and I haven’t seen it running while the bike was running but I also haven’t ran the bike very long just down the road and back a couple times
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Got it all together intake side of cam on the tighter side of spec exhaust was in nice fires right up now on idle knob pulled out will idle but will die after some time push the knob in it dies unless on gas just a little I notice when it idles it’s not very smooth you can keep the rpm jumping any ideas?
 

·
Super Moderator
Joined
·
10,076 Posts
Got it all together intake side of cam on the tighter side of spec exhaust was in nice fires right up now on idle knob pulled out will idle but will die after some time push the knob in it dies unless on gas just a little I notice when it idles it’s not very smooth you can keep the rpm jumping any ideas?
What's the TPS voltage...0.58~0.62DCV @ Idle & 3.7~4.1DCV @ WOT

Your quote (Got it all together intake side of cam on the tighter side of spec)
The Intake valve clearance should be 0.14mm...If it 0.10mm or too close, will prevent the valve to close completely when the motor is hot, causing bad performance
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
TPS voltage is good adjusted it to .61 and 3.9 wot
I’ll pick up a smaller shim and put in the intake side it’s very small amount out not even a thou not sure if it will make it do this but I will definitely adjust it. Sounds to me maybe not enough fuel going to tear the pump down tomorrow and just see how it looks maybe go ahead replace it if I can get one fast
 
1 - 6 of 6 Posts
Top