450 running rich - Kawasaki KFX450 Forum :: KFX450HQ.com
General Discussion Talk about anything on your mind here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-17-2019, 10:47 AM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 2
View jpeltier's Photo Gallery(0)
450 running rich

Hello i am a new owner of a 2008 kfx 450 and she is all stock. when riding it yesterday i opened it up and when i went to slow down and pulled the clutch in, it just killed on me. The guy that was riding with me said that when i got on it, I had black smoke coming out of the exhaust. I am thinking i am running rich, but could be wrong. Has anyone ever had this issue or came across someone who did? thanks in advance.
jpeltier is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-17-2019, 04:54 PM
Senior Member
 
blue99stroker's Avatar
 
Join Date: Jan 2014
Location: Northern California
Posts: 1,835
View blue99stroker's Photo Gallery(0)
Have you pulled the plug to see if it’s black/fouled?

Might just need the idle turned up a bit

08 KFX450r- DASA, FCI, Stage 2 Hotcams, Wiseco Programmer, Procom, Dynatek Coil, 6K HID, 7" LED Light Bar.

Race Tech dual rate front springs, GT thunder XC Link and Race tech spring, LSR +2 a arms, Tusk Extended Rear Hubs

Poly Case Saver, Streamline Stabilizer, Full PRM Skidplates, Pro Armor Bumpers, Tusk Heel Guards, IMS 3.7 tank

Next up: Dasa head port, JE 12.8 piston and 21x12x8 6 paddle skat trak extremes.
blue99stroker is offline  
post #3 of 4 (permalink) Old 06-18-2019, 03:08 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 2
View jpeltier's Photo Gallery(0)
No i have not checked the plug as of yet, but i plan to pick one up and change it.
jpeltier is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-20-2019, 07:00 PM
Senior Member
 
Join Date: Jan 2019
Posts: 219
View Blayzin212's Photo Gallery(0)
When i got my kfx it was doing the same thing. Mine was the map sensor, but it could be the coolant temp sensor, a failing ignition, a throttle position sensor, or a small hand full of other things. Lol but seriously though it would be a good idea if you are going to keep it a while if you would get familiar with removing the seat, front half of the plastic, and the gas tank, because maintenance will require it. My map sensor wasnt bad but the hose going to it came off...easy fix and its a possibility but you need to remove the gas tank to see it. Its right next to the throttle body, like 3 inches away and should be connected by a small hose. Should be the only hose there but its like impossible to see without taking the tank off.
Blayzin212 is offline  
Reply

  Lower Navigation
Go Back   Kawasaki KFX450 Forum :: KFX450HQ.com > KFX450 Headquarters > General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KFX450 Forum :: KFX450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome