My '08 won't idle without the idle screw pulled out - Kawasaki KFX450 Forum :: KFX450HQ.com
General Discussion Talk about anything on your mind here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-14-2019, 01:09 PM Thread Starter
Junior Member
 
Join Date: Jan 2018
Location: SLC UT
Posts: 8
View jasonbiggy's Photo Gallery(0)
My '08 won't idle without the idle screw pulled out

Hi Jason here. My '08 won't idle without the idle screw pulled out. Once I open the butterfly it runs like a champ. I read online another guy had the same problem. He said his butterfly was completely closed at idle also. He adjusted the butterfly to factory spec then adjusted tps to factory spec and fixed the problem. Has anyone else heard of this? Thanks ahead of time
jasonbiggy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-15-2019, 01:05 PM
Senior Member
 
blue99stroker's Avatar
 
Join Date: Jan 2014
Location: Nothern California
Posts: 1,779
View blue99stroker's Photo Gallery(0)
Try advancing the idle speed
The cold start knob also adjusts idle speed by turning it

Also order a Kawasaki tps adapter and check the tps

08 KFX450r- DASA, FCI, Stage 2 Hotcams, Wiseco Programmer, Dynatek Coil, 6K HID, 7" LED Light Bar.

Poly Case Saver, Streamline Stabilizer, Full PRM Skidplates, Pro Armor Bumpers, Tusk Heel Guards, TRX Rear Hubs, Bar risers, IMS 3.7 tank

Skat Trak, STI Tech 4 XC

Next mods- JE 12.8(Thanks coop!), ported head, a arms, axle
blue99stroker is offline  
post #3 of 3 (permalink) Old Yesterday, 03:07 PM
Senior Member
 
Join Date: Jan 2019
Posts: 100
View Blayzin212's Photo Gallery(0)
You are either getting too much gas or too little air....it could be the air filter soaked in oil if you have had it standing on the sissy bar or wrecked it.

If u pull the air screw out and it runs that means u have added a little bit more air and thats what it needs to run...so more than likely it doesnt need more air, so that means its supplying too much fuel...either the coolant temp sensor is bad...20$ on ebay. Or the tps isnt in the correct place along with the cold air screw adjustment is off....if the little vacuum line going from the throttle body(beside the air screw) to the map sensor is leaking or unhooked it will give too much fuel and wont idle...(happened to me) i would check the vacuum line first if i were u.

Sent from my SAMSUNG-SM-G935A using Tapatalk
Blayzin212 is offline  
Reply

  Lower Navigation
Go Back   Kawasaki KFX450 Forum :: KFX450HQ.com > KFX450 Headquarters > General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KFX450 Forum :: KFX450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't run without idle screw pulled out jasonbiggy Engine/EFI/Drivetrain 1 05-15-2019 06:27 PM
Kfx won't idle jasonbiggy Member Introductions 6 03-08-2018 10:45 PM
It's just a throttle body, don't be skeerd Duster Important Information 44 02-05-2018 08:03 AM
Idle screw/tuning/fuel programmer question Davinjw Engine/EFI/Drivetrain 3 04-06-2017 01:46 AM
KFX450R inconsistent idle after warm up Dirtslinger Engine/EFI/Drivetrain 14 09-12-2016 08:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome