Fuel pump not coming on - Kawasaki KFX450 Forum :: KFX450HQ.com
General Discussion Talk about anything on your mind here.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 05-29-2018, 08:38 PM Thread Starter
Member
 
Graffam64's Avatar
 
Join Date: Jan 2017
Posts: 45
View Graffam64's Photo Gallery(0)
Fuel pump not coming on

I ice raced my wheeler back in February for the final time and it has been that long since i have started it. I went to start it the other day and everything comes on as usual except the fuel pump. I thought the pump was junk so I bought a new one same issue. I've checked all fuses checked roll over sensor and now have bought the roll over sensor cancel out plug (kms I beleive) still nothing i am at a loss. any help or suggestions are greatly appreciated
Graffam64 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 05-30-2018, 03:02 PM
Super Moderator
Premium Member
 
Dust Devil's Avatar
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 9,385
View Dust Devil's Photo Gallery(0)
Quote:
Originally Posted by Graffam64 View Post
I ice raced my wheeler back in February for the final time and it has been that long since i have started it. I went to start it the other day and everything comes on as usual except the fuel pump. I thought the pump was junk so I bought a new one same issue. I've checked all fuses checked roll over sensor and now have bought the roll over sensor cancel out plug (kms I beleive) still nothing i am at a loss. any help or suggestions are greatly appreciated
Swap out the relay with one of the other relays to see if that's the problem... see pic

Also make sure the battery is fully charged & holding...12.8 volts standard...!!
Attached Thumbnails
Click image for larger version

Name:	Relays.JPG
Views:	45
Size:	115.4 KB
ID:	23618  

Check with Site Sponsors "First"

(Immortal ATV)
Todd
http://immortalatv.com
1-(800)380-9646
[email protected]
Save 5% off $100 or more, use coupon code: KFX450HQ

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com

(Discount Tire)
At The Store: www.discounttire.com
To Your Door: www.discounttiredirect.com
Sales and Technical: 1.888.459.4080




Dust Devil is offline  
post #3 of 10 (permalink) Old 05-31-2018, 06:38 AM Thread Starter
Member
 
Graffam64's Avatar
 
Join Date: Jan 2017
Posts: 45
View Graffam64's Photo Gallery(0)
Update. I swapped out a couple diff relays and still nothing. It's weird it litteraly sat in the shed for 2.5 months and now the fuel pump issue. I'll check the battery voltage and test light some wires tonight but the wheeler cranks right over like nothing but I guess still possible a battery issue
Graffam64 is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 05-31-2018, 08:53 AM
Super Moderator
Premium Member
 
Dust Devil's Avatar
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 9,385
View Dust Devil's Photo Gallery(0)
Quote:
Originally Posted by Graffam64 View Post
Update. I swapped out a couple diff relays and still nothing. It's weird it litteraly sat in the shed for 2.5 months and now the fuel pump issue. I'll check the battery voltage and test light some wires tonight but the wheeler cranks right over like nothing but I guess still possible a battery issue

Check for 12v at the fuel pump connection see pic...

Also test for 12v on the Y/R wire to frame ground at the ignition coil...see pic

I also included a picture of the fuel pump circuit...see pic
Attached Thumbnails
Click image for larger version

Name:	fuel pump connection.JPG
Views:	74
Size:	59.9 KB
ID:	23625   Click image for larger version

Name:	ignition coil connections.JPG
Views:	74
Size:	43.5 KB
ID:	23633   Click image for larger version

Name:	Fuel Pump circuit.JPG
Views:	62
Size:	101.2 KB
ID:	23641  

Check with Site Sponsors "First"

(Immortal ATV)
Todd
http://immortalatv.com
1-(800)380-9646
[email protected]
Save 5% off $100 or more, use coupon code: KFX450HQ

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com

(Discount Tire)
At The Store: www.discounttire.com
To Your Door: www.discounttiredirect.com
Sales and Technical: 1.888.459.4080




Dust Devil is offline  
post #5 of 10 (permalink) Old 06-15-2018, 04:50 PM Thread Starter
Member
 
Graffam64's Avatar
 
Join Date: Jan 2017
Posts: 45
View Graffam64's Photo Gallery(0)
So I have power to the coil wire I have power to all my relays and fuses just don't have power at the fuel pump connection
Graffam64 is offline  
post #6 of 10 (permalink) Old 06-15-2018, 07:48 PM
Super Moderator
Premium Member
 
Dust Devil's Avatar
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 9,385
View Dust Devil's Photo Gallery(0)
Quote:
Originally Posted by Graffam64 View Post
So I have power to the coil wire I have power to all my relays and fuses just don't have power at the fuel pump connection
When testing the power at the fuel pump connection on the W/R + & BK/W - wires...you know that you'll only have power for 3-seconds when you turn the key ON....???

Check with Site Sponsors "First"

(Immortal ATV)
Todd
http://immortalatv.com
1-(800)380-9646
[email protected]
Save 5% off $100 or more, use coupon code: KFX450HQ

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com

(Discount Tire)
At The Store: www.discounttire.com
To Your Door: www.discounttiredirect.com
Sales and Technical: 1.888.459.4080




Dust Devil is offline  
post #7 of 10 (permalink) Old 06-16-2018, 09:34 AM Thread Starter
Member
 
Graffam64's Avatar
 
Join Date: Jan 2017
Posts: 45
View Graffam64's Photo Gallery(0)
Yes I know the 3 seconds I can hear my relay click and then click again in 3 seconds but I am still getting no power to my fuel pump plug.
Graffam64 is offline  
post #8 of 10 (permalink) Old 06-16-2018, 09:51 AM Thread Starter
Member
 
Graffam64's Avatar
 
Join Date: Jan 2017
Posts: 45
View Graffam64's Photo Gallery(0)
I apologize. I do not have any power coming from the white/red wire coming from the ecu , the relay, or the fuel pump
Graffam64 is offline  
post #9 of 10 (permalink) Old 06-16-2018, 10:31 AM
Super Moderator
Premium Member
 
Dust Devil's Avatar
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 9,385
View Dust Devil's Photo Gallery(0)
Quote:
Originally Posted by Graffam64 View Post
I apologize. I do not have any power coming from the white/red wire coming from the ecu , the relay, or the fuel pump
Ok!...Power comes from the battery on the W/BK through the fuse then relay & then the W/R wire to the pump....(Note) the ECU picks up the power on the W/R from the relay for the ECU igniter circuit for the ignition coil & injector pulse...

Check for 12v power to frame ground at the two points in red...Picture below...!

Also make sure your meters Black negative lead is to frame ground when testing the fuel pump's W/R wire...

If you have power through the Fuse & relay to the W/R fuel pump wire, I'm suspecting either your tip over bypass sensor or ECU is faulty...

Test the output voltage of your vehicle down (KMS) bypass plug... output voltage should be 3.7~4.4 DCV
Attached Thumbnails
Click image for larger version

Name:	Capture.JPG
Views:	63
Size:	106.7 KB
ID:	23978  

Check with Site Sponsors "First"

(Immortal ATV)
Todd
http://immortalatv.com
1-(800)380-9646
[email protected]
Save 5% off $100 or more, use coupon code: KFX450HQ

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com

(Discount Tire)
At The Store: www.discounttire.com
To Your Door: www.discounttiredirect.com
Sales and Technical: 1.888.459.4080





Last edited by Dust Devil; 06-16-2018 at 10:45 AM.
Dust Devil is offline  
post #10 of 10 (permalink) Old 07-14-2018, 02:26 PM Thread Starter
Member
 
Graffam64's Avatar
 
Join Date: Jan 2017
Posts: 45
View Graffam64's Photo Gallery(0)
It was a broken wire in a weird spot just before the relay. I just about had the whole harness out and found it. Thanx dust devil ur pics helped find the issue
Graffam64 is offline  
Reply

  Lower Navigation
Go Back   Kawasaki KFX450 Forum :: KFX450HQ.com > KFX450 Headquarters > General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KFX450 Forum :: KFX450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump running elkhunterman Engine/EFI/Drivetrain 9 01-10-2017 04:01 PM
Fuel pump bad?? opinions please madpb Engine/EFI/Drivetrain 38 09-30-2016 12:37 AM
Fuel pump not turning on! Escobedo89 Engine/EFI/Drivetrain 11 05-24-2016 06:48 PM
Fuel pump options mr.bigwheel Engine/EFI/Drivetrain 6 01-26-2016 10:33 PM
No spark or power to fuel pump HELP PLEASE Jared08 Engine/EFI/Drivetrain 25 01-09-2016 12:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome