Needing some ideas regarding procom - Kawasaki KFX450 Forum :: KFX450HQ.com
Engine/EFI/Drivetrain Discuss engine, fuel injection, air intake, and drivetrain modifications here.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-08-2019, 06:50 PM Thread Starter
Junior Member
 
Korreaa's Avatar
 
Join Date: Dec 2014
Posts: 13
View Korreaa's Photo Gallery(0)
Needing some ideas regarding procom

Hello fellow KFX'ers...............................So on a previous thread I wrote ended up finding out the accel coil was the issue so I went back to stock and it runs flawlessly now WOOO HOOOO Thank you Stroker and Devil for the help by the way.

So now having a new problem I just cant figure out.....with the mods that I have with the OEM ecu and PCV hooked up runs great no problems at all!!!!!! but when I hook up the procom ecu with my PCV it acts like it doesnt even want to start procom map set on 0 by the way and the I do have the PPR firmware to .5 Which should mirror my oem ECU so im not understanding why it isnt starting......I also own 2 procom ecu's 1 brand new in box and one ive been using for years and it does the same with BOTH procom ecu's.................I would love to see some ideas from you guys cause im at a dead end. I really want to run the procom due to the rev limiter and better shifting. Again thanks to everyone for the help and ideas hopefully I can get this thing figured out so I can use it to its full potential.

so again with the mods that are currently on my bike

08 kfx450r
PCV with oem
PCV with Procom with the PPR set to .5
99.3 piston
+1 valves
web cams
bored throttle body
3mm crank
ct racing ported head
FCI intake
Korreaa is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-08-2019, 07:29 PM
Super Moderator
Premium Member
 
Dust Devil's Avatar
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 9,414
View Dust Devil's Photo Gallery(0)
Have you tried it with map 1 or 2 to see if it will start instead of map 0...?
&
Does it start with just the Procom on map 8 or 9 with the mods you have...with the PCV disconnected...???

With the OEM ecu hooked up does your F.I light remain ON showing an DFI error code...??? see picture

Check your water temp sensor connection...??
Attached Thumbnails
Click image for larger version

Name:	Self diagnosis.JPG
Views:	9
Size:	127.6 KB
ID:	24380  

Check with Site Sponsors "First"

(Immortal ATV)
Todd
http://immortalatv.com
1-(800)380-9646
[email protected]
Save 5% off $100 or more, use coupon code: KFX450HQ

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com

(Discount Tire)
At The Store: www.discounttire.com
To Your Door: www.discounttiredirect.com
Sales and Technical: 1.888.459.4080





Last edited by Dust Devil; 06-08-2019 at 07:47 PM.
Dust Devil is offline  
post #3 of 9 (permalink) Old 06-09-2019, 08:09 AM Thread Starter
Junior Member
 
Korreaa's Avatar
 
Join Date: Dec 2014
Posts: 13
View Korreaa's Photo Gallery(0)
Hello Dust I have not tried the procom by itself yet reason being no one around me knows how to use the tuning software for procom but now that you mention I will give that a try ill give you update once its done today.....Also yes FI light does stay on with oem ecu but I ran the service code and it gives me fuel pump relay which ive already replaced and my fuel pump just keeps pumping/priming I think I may have shorted something in oem ecu BUT I dont think any harm is done with the fuel pump constantly running am I correct? Also water temp sensor is new but it wasnt a name brand or oem one if that matters? Ebay temp switch if you want me to be honest.
Korreaa is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 06-09-2019, 05:24 PM
Super Moderator
Premium Member
 
Dust Devil's Avatar
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 9,414
View Dust Devil's Photo Gallery(0)
Quote:
Originally Posted by Korreaa View Post
Hello Dust I have not tried the procom by itself yet reason being no one around me knows how to use the tuning software for procom but now that you mention I will give that a try ill give you update once its done today.....Also yes FI light does stay on with oem ecu but I ran the service code and it gives me fuel pump relay which ive already replaced and my fuel pump just keeps pumping/priming I think I may have shorted something in oem ecu BUT I dont think any harm is done with the fuel pump constantly running am I correct? Also water temp sensor is new but it wasnt a name brand or oem one if that matters? Ebay temp switch if you want me to be honest.
Does the fuel pump run constantly with the OEM ECU & Procom or just the OEM ECU...???

The fuel pump should not run constantly especially at Idle or 1/4 throttle due to the increasing of fuel pressure beyond the 43 psi damaging/wearing out the injector nozzle ...also it will wear out the fuel pump prematurely & damage the fuel regulator/check valve....So you should find/fix the problem before it worsens/bigger problem...

pull the fuel pump relay & see if the pump turns off...then trouble shoot from there to find the cause...see picture below to help you
Attached Thumbnails
Click image for larger version

Name:	Fuel Pump circuit.JPG
Views:	12
Size:	101.2 KB
ID:	24382  

Check with Site Sponsors "First"

(Immortal ATV)
Todd
http://immortalatv.com
1-(800)380-9646
[email protected]
Save 5% off $100 or more, use coupon code: KFX450HQ

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com

(Discount Tire)
At The Store: www.discounttire.com
To Your Door: www.discounttiredirect.com
Sales and Technical: 1.888.459.4080




Dust Devil is offline  
post #5 of 9 (permalink) Old 06-10-2019, 10:58 PM Thread Starter
Junior Member
 
Korreaa's Avatar
 
Join Date: Dec 2014
Posts: 13
View Korreaa's Photo Gallery(0)
We are on to something Dust!!!........ I havent found enough time off work yet to test the only run bike on pro com ecu without the pcv but you are absolutely CORRECT fuel pump stays on with oem ecu and throws fuel pump relay open code BUT with pro com it does the normal pump ON for 3-4 secs then shuts off as normal. Also I have one trail ride 17miles worth on and Brand new pump and regulator Quantum brand "ebay" lol or "Amazon" one of the 2 and I had another before that with only 16miles worth of trail but same symptoms.....should I be fine? fuel pump does not turn on when relay out..........since relay runs as it should does that eliminate 2-8 on the fuel pump circuit?
Korreaa is offline  
post #6 of 9 (permalink) Old 06-11-2019, 01:37 AM
Super Moderator
Premium Member
 
Dust Devil's Avatar
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 9,414
View Dust Devil's Photo Gallery(0)
Quote:
Originally Posted by Korreaa View Post
We are on to something Dust!!!........ I havent found enough time off work yet to test the only run bike on pro com ecu without the pcv but you are absolutely CORRECT fuel pump stays on with oem ecu and throws fuel pump relay open code BUT with pro com it does the normal pump ON for 3-4 secs then shuts off as normal. Also I have one trail ride 17miles worth on and Brand new pump and regulator Quantum brand "ebay" lol or "Amazon" one of the 2 and I had another before that with only 16miles worth of trail but same symptoms.....should I be fine? fuel pump does not turn on when relay out..........since relay runs as it should does that eliminate 2-8 on the fuel pump circuit?
I'm suspecting from the test performed...the OEM ECU might have an internal short causing the error code & the pump running non stop...

Can you try and start it with just the Procom ON map 8~9 with the PCV disconnected...If it doesn't then it might be the firmware is corrupted or it's the wrong PPR rate causing it not to work with the PCV on map zero...

Did Dynojet send you firmware for 0.5, 1.0 & 2.0 PPR rate firmware or just the 0.5 firmware was sent...???

If you have the 1.0 PPR rate firmware try that & see if it runs on map zero with the PCV connected..

Check with Site Sponsors "First"

(Immortal ATV)
Todd
http://immortalatv.com
1-(800)380-9646
[email protected]
Save 5% off $100 or more, use coupon code: KFX450HQ

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com

(Discount Tire)
At The Store: www.discounttire.com
To Your Door: www.discounttiredirect.com
Sales and Technical: 1.888.459.4080





Last edited by Dust Devil; 06-11-2019 at 01:46 AM.
Dust Devil is offline  
post #7 of 9 (permalink) Old 06-12-2019, 01:09 PM Thread Starter
Junior Member
 
Korreaa's Avatar
 
Join Date: Dec 2014
Posts: 13
View Korreaa's Photo Gallery(0)
Dynojet sent me the 1.5 and I also have the 1.0 that was sent to me from a kfx450hq member.........Will update you once I do the testing on 6-13-19 my day off lol
Korreaa is offline  
post #8 of 9 (permalink) Old 06-30-2019, 08:04 PM Thread Starter
Junior Member
 
Korreaa's Avatar
 
Join Date: Dec 2014
Posts: 13
View Korreaa's Photo Gallery(0)
ALRIGHTY GUYS!!!!! First I want to say thank you again Dust DEvil for the help, I took out the PCV only running PROCOM on map 8 an SHE IS WICKED!! no hick ups, no stalls, throttle response isnt finicky anymore runns perfect!!!!! also found out my tps sensor doesnt click in fully so when you start the motor it will slide out from vibration causing NO STARTS THANKS again for all the help I REFUSE to sell this quad lol
Korreaa is offline  
post #9 of 9 (permalink) Old 07-07-2019, 01:12 PM
Senior Member
 
Join Date: Jan 2019
Posts: 177
View Blayzin212's Photo Gallery(0)
Hey could you send me this update from dynojet please.? I have a pcv and procom and would like to try it.
Thank you

Sent from my SAMSUNG-SM-G935A using Tapatalk
Blayzin212 is online now  
Reply

  Lower Navigation
Go Back   Kawasaki KFX450 Forum :: KFX450HQ.com > KFX450 Performance > Engine/EFI/Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KFX450 Forum :: KFX450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome