Kawasaki KFX450 Forum :: KFX450HQ.com - View Single Post - 08 kfx450 fi light flashing during turn over
View Single Post
post #2 of (permalink) Old 03-19-2019, 03:32 AM
Dust Devil 
Super Moderator
Premium Member
 
Dust Devil's Avatar
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 9,524
View Dust Devil's Photo Gallery(0)
Quote:
Originally Posted by Aydastone View Post
Got an 08 kfx450. Was having problems not starting. Originally it would run for 3 secs then shut off. Took the plastics off, seen the tip over sensor came off its bracket. Put it back on, reset it, and it started. Shut it off, did it a couple times to make sure everything thing was good, then the fi light started to flash during turn over. It doesn't stay on, only flashes as I'm cranking her over, so it shows no codes. Started wiggling shit and seen that if I twist the Injector a quarter of an inch, fi light would shut off and it would start. Move it the other way, fi light back on wouldn't start. Did this 5 times until it stopped all together. Now no matter which way you twist the injector, fi light is on during cranking and won't start. It doesn't move in and out, just twists back and forth. I need to take my harness off and go completely through it, but is this just a faulty injector where is started to short out the first 5 times, then went completely out? Was told it's not supposed to move at all. Any ideas? In the pictures you can barely see the difference but the first picture the plug is moved up where there's a gap between the plug and injector. Second picture the plug is moved down where there's no gap. I'd upload a video if someone knows how. Thanks in advance
First...Is your KFX all stock or has motor upgrades...!! List any motor mods it may have...

Make sure the battery is fully charged...12,8 volts standard...

Pull the injector electrical connector off & clean it thoroughly with some electronic spray...

Then do a ohms/resistance test of the injector...!! see picture below..!

A flashing F.I light is the tip-over sensor activated signal...!!! So double check your tip-over senor's output voltage to make sure it's operating properly...see picture below

Also check if the throttle positioning sensor is in range...0.58~0.62 dcv @ throttle close...3.7~4.1 dcv @ WOT throttle wide open...see picture below
Attached Thumbnails
Click image for larger version

Name:	fuel injector resistance.JPG
Views:	25
Size:	72.4 KB
ID:	24282   Click image for larger version

Name:	fuelinjectorcircuit.jpg
Views:	24
Size:	207.5 KB
ID:	24286   Click image for larger version

Name:	vehicle down sensor test.JPG
Views:	53
Size:	139.4 KB
ID:	24290   Click image for larger version

Name:	TPS voltage inspection.JPG
Views:	29
Size:	118.2 KB
ID:	24292  

Check with Site Sponsors "First"

(Immortal ATV)
Todd
http://immortalatv.com
1-(800)380-9646
[email protected]
Save 5% off $100 or more, use coupon code: KFX450HQ

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com

(Discount Tire)
At The Store: www.discounttire.com
To Your Door: www.discounttiredirect.com
Sales and Technical: 1.888.459.4080




Dust Devil is offline  
 
 
For the best viewing experience please update your browser to Google Chrome