Kawasaki KFX450 Forum :: KFX450HQ.com - View Single Post - 08 kfx450 fi light flashing during turn over
View Single Post
post #1 of (permalink) Old 03-18-2019, 05:14 PM Thread Starter
Aydastone
Junior Member
 
Join Date: Mar 2019
Posts: 1
View Aydastone's Photo Gallery(0)
08 kfx450 fi light flashing during turn over

Got an 08 kfx450. Was having problems not starting. Originally it would run for 3 secs then shut off. Took the plastics off, seen the tip over sensor came off its bracket. Put it back on, reset it, and it started. Shut it off, did it a couple times to make sure everything thing was good, then the fi light started to flash during turn over. It doesn't stay on, only flashes as I'm cranking her over, so it shows no codes. Started wiggling shit and seen that if I twist the Injector a quarter of an inch, fi light would shut off and it would start. Move it the other way, fi light back on wouldn't start. Did this 5 times until it stopped all together. Now no matter which way you twist the injector, fi light is on during cranking and won't start. It doesn't move in and out, just twists back and forth. I need to take my harness off and go completely through it, but is this just a faulty injector where is started to short out the first 5 times, then went completely out? Was told it's not supposed to move at all. Any ideas? In the pictures you can barely see the difference but the first picture the plug is moved up where there's a gap between the plug and injector. Second picture the plug is moved down where there's no gap. I'd upload a video if someone knows how. Thanks in advance
Attached Thumbnails
Click image for larger version

Name:	20190318_161057_1552939932632.jpg
Views:	36
Size:	1.24 MB
ID:	24278   Click image for larger version

Name:	20190318_161110_1552939947132.jpg
Views:	34
Size:	1.23 MB
ID:	24280  
Aydastone is offline  
 
 
For the best viewing experience please update your browser to Google Chrome