Go Back   Kawasaki KFX450 Forum :: KFX450HQ.com > KFX450 Performance > Important Information

Important Information How-to's, install guides, tech advice, and reviews of aftermarket KFX450 parts.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12-20-2010, 01:10 PM
Dust Devil's Avatar
Premium Member
Premium Member
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 7,626
View Dust Devil's Photo Gallery(0)
Exclamation "Warning about Dynatek F.S ignition & DRSP-1"..!!!!!!

The Dynatek ignition has cost-ed me $450.00 and has destroyed both the original DFS2-21 & a replacement DFS2-21 ignition...

upon installation within 3-seconds of hitting the starter button...

2-ECU $400.00 (list price $266.00.) www.bikebandit.com
1-stator $189.00
water temp sensor $ 35.00
gunnar kill switch $30.00
injector nozzle.$75.00
$ 160.00 labor.. at www.waltsmotorsports.com .
Have a new ECU ordered from Ebay $125.00 (new)

Total.damage $1107.00 + $450.00 purchase price for the DRSP-1 & DFS2-21 ignition....

Purchase at your own Risk....!!!!!!
__________________
Check with Site Sponsors "First"

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com



(Zbroz racing)
http://www.zbrozracing.com


I'm building a "Nitrous Hill-Climber"!!!

Reply With Quote
KFX450HQ.com is the premier Kawasaki KFX Forum on the internet. Registered Users do not these ads. Please Register - It's Free!    
  #2 (permalink)  
Old 12-20-2010, 03:47 PM
nkeen07's Avatar
Senior Member
 
Join Date: Dec 2008
Posts: 3,488
View nkeen07's Photo Gallery(0)
Thanks for letting us know man. Are you running their coil by any chance?
__________________
Reply With Quote
  #3 (permalink)  
Old 12-20-2010, 06:11 PM
ononewheel's Avatar
Premium Member
Premium Member
 
Join Date: Feb 2009
Location: warwick,RI
Posts: 5,185
View ononewheel's Photo Gallery(1)
is that meant for are atv's?why did it fry your shit?details please!
__________________
2010yfz450x race bike 1
2010yfz450x race bike 2

2014 SPONSORS

ZBROZ RACING
FASSTCO
FMF
FLY RACING
FOX
KENDA
PRO ARMOR
HOT CAMS
HOT RODS
VERTEX
PIVOT WORKS
CYLINDER WORKS
SG GRAFFIX
SCOTT
JT SPROCKETS
REKLUSE
MOTOEXPERTS
NACS RACING
ODI
1.7 CLEANING SOLUTIONS
HIPER RACING
PRECISION RACING
LIFEPROOF
AMSOIL


Reply With Quote
  #4 (permalink)  
Old 12-20-2010, 07:51 PM
Dust Devil's Avatar
Premium Member
Premium Member
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 7,626
View Dust Devil's Photo Gallery(0)
Thumbs up

Quote: Originally Posted by nkeen07 View Post
Thanks for letting us know man. Are you running their coil by any chance?
yes...

Quote: Originally Posted by ononewheel View Post
is that meant for are atv's?why did it fry your shit?details please!
It's the DFS2-21 for the KFX450R ...

Also add A TPS to the list $130.00....Grand total in repairs $1300.00.

I purchased it and hooked it up in Sept, Hit the starter button and it spiked my System & Blew out my Injector nozzle,ECU,Crank sensor, & damaged my Kill switch (N/O)...Sent it back for testing...Sent back "They said it was fine"hooked it back up...with a new Stator and ECU...Hit the starter button...Engine light came "On" and then Sent it to www.waltsmotorsports.com . The dealer I purchased my kFX450R from.....They determined the Dynatek is faulty....
Fried my ECU, Injector nozzle, water temp sensor And the gunnar Kill switch (N/O) the resistor on the kill switch fried....
I can show pictures of the kill switch so you will understand..Sent it back...They then determined it had Issues...and sent a replacement....

Hooked it up..And Engine light remains "On" and removed the DFS and the Engine light goes out "NO code"

The ECU and TPS are now Fried though.....And they want be to hook it up to a third ECU saying I don't know what I'm doing....

There warranty is only for they system and not what it destroys

Which explains all my postings since September....

TPS dilemma going on.... - Kawasaki KFX450 Forum :: KFX450HQ.com


Fuel injector Gone "Bad" - Kawasaki KFX450 Forum :: KFX450HQ.com

Ricky Stator crank sensor/Trigger replacement.... - Kawasaki KFX450 Forum :: KFX450HQ.com

Here's there reply...

Wow, the things that happen over a weekend! If our system was a faulty design, I do not believe the pre-production units would have tested good on the first bike we designed the system for.
Secondly, I find it hard to believe that there are over 100 people with our systems since May that are having problems, like yours, but not calling us.
Thirdly, your buying US and I am very happy; I wish everyone was doing that. Your system, was either built here in Glendora, California, or in Montana, which is where the production building has gone to in the last 2 months. Isn't that where you sent your system to have it tested?
Lastly, I want you to remember the point of this system, is that it is a "piggyback system". All of the power is coming from your vehicle, as we do not supply the power for it- your ignition does. The system cannot ruin the injector, as we are only reading the information, same with the TPS input. Please note that you had tested the system at least 3 times with the wrong readings because you were hooking the multi-meter incorrectly, which we pointed out to you; after which you got the reading that we were looking for-
I only had the DFS injector hooked up & got the reading on the brown/red wire 11.80v....Note: I got the same voltage from the stock connector White/Red wire..11.80v that feed the DFS ignition....
At this point, we do not know what condition your ECU was in, or which ECU you were using, as the reading for every test you did fluctuated several times in the 18 emails you have sent me. The other note is that with your incorrect testing procedures, as the pictures you sent shows, could have easily caused the problems with all the components you tested, incorrectly I might add.
With that being said, I would like to invite you to return the system so that we may find out what went wrong with the installation, the hookup, the testing of if the unit, and of course, if it still tests or works fine, as it did when we last tested the unit, we can return it to you at no cost and our test results in black and white. The same RA#, RA-16908 is still available and awaiting the return of the component we spoke about.
If I can be of further assistance, please do not hesitate to contact me again.
Sincerely
Raymond Goshorn
Customer Service Manager
Dynatek
TF: 800.928.DYNA (3962)
rgoshorn@dynaonline.com
__________________
Check with Site Sponsors "First"

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com



(Zbroz racing)
http://www.zbrozracing.com


I'm building a "Nitrous Hill-Climber"!!!


Last edited by Dust Devil; 12-20-2010 at 08:02 PM.
Reply With Quote
  #5 (permalink)  
Old 12-20-2010, 09:21 PM
Dust Devil's Avatar
Premium Member
Premium Member
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 7,626
View Dust Devil's Photo Gallery(0)
Thumbs up

If anyone doubts my situation with the Dynatek ignition,

I have a Free DRSP-1 & Two DFS2-21 you can try on your quad, "The damn thing is cursed I tell ya"

I haven't rode my quad since Sept when the DFS2-21 fried my system and I spent 3-months & replacement DFS2-21 and $1300.00 to fix it...

3rd ECU ordered new on Ebay $125.00

and a new TPS being ordered after the Holidays $130.00

And maybe I can ride my quad for a change...Instead of arguing, why it doesn't run & lost $1300.00 repairs + $450.00 purchase price of DFS2-21 & DRSP-1 = $1750.00..."AND IT DON'T START NOR IDLE"!!!!!!!!!!!!!

Numbers don't lie, when it's the balance of your checking account...

I'm waiting to here from MSD for they said in the past they are now working on releasing their F.I blasters for other models including the KFX450R.....I should have shown patients and waited....
Attached Images
File Type: jpg 000_0252.jpg (78.1 KB, 27 views)
File Type: jpg 000_0167.jpg (87.5 KB, 28 views)
File Type: jpg 000_0293.jpg (97.8 KB, 26 views)
__________________
Check with Site Sponsors "First"

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com



(Zbroz racing)
http://www.zbrozracing.com


I'm building a "Nitrous Hill-Climber"!!!

Reply With Quote
  #6 (permalink)  
Old 12-20-2010, 09:42 PM
Duster's Avatar
Senior Member
 
Join Date: Mar 2009
Location: North Carolina
Posts: 11,144
View Duster's Photo Gallery(0)
What a bunch of snide idiots.


Stuff like that is pretty much an idiot proof install... Power, ground, and piggyback connector.

I don't see how it is possible to install it wrong unless the connectors are wrong.
__________________
CIRCUS RUNAWAYS RACING
#919 KFX450R



2014 Sponsors:
Circus Runaways Racing, NineOneNine Designs, X-TREAM CLEAN,
Wicked Thunder, CV4, ATV Four-Play, Teixeira Tech, Fox Racing Shox,
Houser Racing, Vanilla Gorrilla Racing, Yoshimura, Wiseco, Rekluse,
Turbo Blue Race Fuel, Rath Racing, ITP Tire & Wheel, KB Motorsports


Reply With Quote
  #7 (permalink)  
Old 12-20-2010, 10:01 PM
Senior Member
 
Join Date: Jan 2010
Location: Tulsa, Ok
Posts: 438
View jeffskfx450's Photo Gallery(0)
[QUOTE=and a new TPS being ordered after the Holidays $130.00[/QUOTE]

If you are interested I might have a tps. I ended up buying a couple of throttle bodies a while back for pretty cheap, and I think they both have a tps on them. Just let me know if you are interested.
Reply With Quote
  #8 (permalink)  
Old 12-20-2010, 10:43 PM
Dust Devil's Avatar
Premium Member
Premium Member
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 7,626
View Dust Devil's Photo Gallery(0)
Thumbs up

[quote=jeffskfx450;67703]
Quote: Originally Posted by and a new TPS being ordered after the Holidays $130.00[/quote

If you are interested I might have a tps. I ended up buying a couple of throttle bodies a while back for pretty cheap, and I think they both have a tps on them. Just let me know if you are interested.
Thanks I already have Dr Dirt here in Havasu going to order me one and hold it for me...

Again Thank you...
__________________
Check with Site Sponsors "First"

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com



(Zbroz racing)
http://www.zbrozracing.com


I'm building a "Nitrous Hill-Climber"!!!

Reply With Quote
  #9 (permalink)  
Old 12-20-2010, 11:06 PM
Dust Devil's Avatar
Premium Member
Premium Member
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 7,626
View Dust Devil's Photo Gallery(0)
Thumbs up

Quote: Originally Posted by Duster View Post
What a bunch of snide idiots.


Stuff like that is pretty much an idiot proof install... Power, ground, and piggyback connector.

I don't see how it is possible to install it wrong unless the connectors are wrong.

Thanks for understanding my situation...All my testing you know it's here on the Forum....I also had Walt's Kawasaki do a diagnosis and found the Dynatek ignition was to blame for the failure...I told Dynatek it was the Kill switch and a loose ground that caused the "Spiked"....

and replace the water temp sensor, and also told me to replace the Gunnar kill switch (N/O)...I'll provide a picture so you'll understand what i'm referring too

Then armed with the Kawi Technicians diagnosis they wanted it re-tested and only then did they find a issue with their DFS ignition...

I gambled and lost $1750.00...

And they still want to replace it a third time and try it again...only there DFS ignition is warranted and will be replaced for free...not the stuff it fries or damages...

No! thank you, I replied...It's going into the trash and not on Ebay...

On a Good note, I got a Go pro hero camera, a seat cover with matching shock covers and Hygear dual rate springs that "Santa delivered early...

here's the seat cover..A local shop will put it on... Kawasaki KFX 450R GN Skull Pile Seat Cover ATV KFX450R - eBay (item 370466200413 end time Jan-11-11 19:23:21 PST)

and here's the shock covers...Shock Covers SKULL PILE GREEN Kawasaki KFX450 KFX 450 - eBay (item 370466183547 end time Jan-11-11 18:13:33 PST)

I'm going back to a stock ignition so I can ride my quad for 2011 only have about 10 mile on it for 2010...

__________________
Check with Site Sponsors "First"

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com



(Zbroz racing)
http://www.zbrozracing.com


I'm building a "Nitrous Hill-Climber"!!!


Last edited by Dust Devil; 12-20-2010 at 11:22 PM.
Reply With Quote
  #10 (permalink)  
Old 12-21-2010, 12:08 AM
Dust Devil's Avatar
Premium Member
Premium Member
 
Join Date: Oct 2009
Location: Lake Havasu city, Arizona
Posts: 7,626
View Dust Devil's Photo Gallery(0)
Here's my response to Dynatek reply....

Hello Raymond,
I haven't rode it since the ignition fried my ECU in sept, hooked it up ,hit the starter button...and problems ever since.....
$1300.00 + the purchase and labor for walt Kawasaki to determine the Dynatek & 2nd ECU are faulty....

The Dynatek ignition has cost-ed me $450.00 to purchase and has destroyed
2-ECU $400.00
1-stator $189.00
water temp sensor $ 35.00
kill switch $30.00
injector nozzle.$75.00
$ 160.00 labor...
I have a third ECU ordered on the way...$125.00
also the TPS is Bad and needs to be replaced $130.00...when I can afford it....

That's when you tested it the second time and found an issue with it....

Well 3-strikes your DFS is going into the trash....

The testing was done by Walt's Kawasaki, where I purchased the KFX450R....

And all my testing is on the Forum ..Fuel injector Gone "Bad" - Kawasaki KFX450 Forum :: KFX450HQ.com.

I'm going to get the new MSD F.I blaster when "Ready"

In regards to this reply Dynatek sent me...
__________________________________________________ ______________________
Here's there reply...

Wow, the things that happen over a weekend! If our system was a faulty design, I do not believe the pre-production units would have tested good on the first bike we designed the system for.
Secondly, I find it hard to believe that there are over 100 people with our systems since May that are having problems, like yours, but not calling us.
Thirdly, your buying US and I am very happy; I wish everyone was doing that. Your system, was either built here in Glendora, California, or in Montana, which is where the production building has gone to in the last 2 months. Isn't that where you sent your system to have it tested?
Lastly, I want you to remember the point of this system, is that it is a "piggyback system". All of the power is coming from your vehicle, as we do not supply the power for it- your ignition does. The system cannot ruin the injector, as we are only reading the information, same with the TPS input. Please note that you had tested the system at least 3 times with the wrong readings because you were hooking the multi-meter incorrectly, which we pointed out to you; after which you got the reading that we were looking for-
I only had the DFS injector hooked up & got the reading on the brown/red wire 11.80v....Note: I got the same voltage from the stock connector White/Red wire..11.80v that feed the DFS ignition....
At this point, we do not know what condition your ECU was in, or which ECU you were using, as the reading for every test you did fluctuated several times in the 18 emails you have sent me. The other note is that with your incorrect testing procedures, as the pictures you sent shows, could have easily caused the problems with all the components you tested, incorrectly I might add.
With that being said, I would like to invite you to return the system so that we may find out what went wrong with the installation, the hookup, the testing of if the unit, and of course, if it still tests or works fine, as it did when we last tested the unit, we can return it to you at no cost and our test results in black and white. The same RA#, RA-16908 is still available and awaiting the return of the component we spoke about.
If I can be of further assistance, please do not hesitate to contact me again.
Sincerely
Raymond Goshorn
Customer Service Manager
Dynatek
TF: 800.928.DYNA (3962)
rgoshorn@dynaonline.com
__________________
Check with Site Sponsors "First"

(KB Motor-sports)
Website:
http://www.kbmotorsportsonline.com



(Zbroz racing)
http://www.zbrozracing.com


I'm building a "Nitrous Hill-Climber"!!!


Last edited by Dust Devil; 12-21-2010 at 12:12 AM.
Reply With Quote
Reply

Lower Navigation
Go Back   Kawasaki KFX450 Forum :: KFX450HQ.com > KFX450 Performance > Important Information


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Search tags for this page

dynatek drsp-1

,

dynatek fs digital ignition

,
dynatek fs programmable ignition
,
dynatek ignition
,
dynatek ignition problems
,
dynatek ignition review
,

dynatek ignition reviews

,
dynatek montana
,
having problems with my f.s. digital ignition
,
testing dyna ignition
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dynatek's F.S Programmable ignition is "Ready" Dust Devil Dyno/Tuning Room 27 08-30-2010 06:54 PM
Titanium Weld "Bung" M18X1.50 For O2 sensors.. Dust Devil Dyno/Tuning Room 11 08-27-2010 01:08 AM
Koso wide-band O2 sensor...Or they "Good" Dust Devil Dyno/Tuning Room 0 04-15-2010 09:19 PM
"Roll Design" and "Elka" mx stuff for sale! RoundIIRacing For Sale/Wanted 2 11-14-2009 06:14 PM


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:03 AM.